Помогите составить программу, которая определяет три целых числа с клавиатуры, являются ли они сторонами прямоугольного треугольника.
var
a,b,c,g : integer;
// a,b,c - стороны
begin
readln (a,b,c);
// g - находим гипотенузу (наибольшее из чисел)
if a > b then
begin
if a > c then
g := a
else
g := c
end
else
if b > c
then
g := b
else
g := c;
// Если треугольник прямоугольный, то
// сумма квадратов катетов равна квадрату гипотенузы
if (sqr (a) + sqr (b) = sqr(g))
or (sqr (a) + sqr (c) = sqr(g)) then
writeln (Yes)
else writeln (No);
end.
Оцени ответ
