Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающихся на 7. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).В последовательности всегда имеется число, оканчивающееся на 7. Количество чисел не превышает 100. Введённые числа не превышают 1000. Программа должна вывести одно число, минимальное число, оканчивающееся на 7.

var   a,min : integer;    
begin 
a := 5; 
min := 1000;   

While a <> 0 do 
 begin   
readln (a);   
if (a mod 10 =7) and (a < min ) then     
min := a;   
end;    
writeln (min); 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку