
Написать программу, реализующую диалог с пользователем: предлагающую выбрать один из следующих вариантов расчета: 1 - расчет тригонометрической функции 2 - расчет квадрата числа 3 - расчет корня числа По нажатии клавиши 1 пользователю предлагаются следующие варианты: s - расчет синуса c - расчет косинуса t - расчет тангенса После выбора соответствующего пункта меню пользователю предлагается ввести число, по которому необходимо провести расчет и после расчета выводится значение. В случае, если пользователь выбрал несуществующий пункт меню ему выдается сообщение об ошибке.

var x:real;
c:char;
begin
readln(c);
readln(x);
if c=1 then begin
readln(c);
if c=s then writeln(sin(x));
if c=c then writeln(cos(x));
if c=t then writeln(sin(x)/cos(x));
end else
if c=2 then
writeln(sqr(x))
else
if c=3 then
writeln(sqrt(x));
end.