Написать программу. Даны 2 числа a и b. Найти среднее арифметическое всех чисел кратных 3 из интервала [a,b].

var
  i, j, a, b: integer;
  s: real;
begin
  write(Введите a: ); readln(a);
  write(Введите b: ); readln(b);
  for i := a to b do
    if (i mod 3) = 0 then
    begin
      s := s + i;
      inc(j);
    end;
  s := s / j;
  writeln(Ответ: , s);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку