Напишите программу, которая в последовательнсти целых чисел определяет количество нечетных чисел, кратных 3. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введеные числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечетных чисел, кратных 3.
ПОЖАЛУУУЙСТА!)

Var a:array[1..1000] of integer;
i,j:integer;
begin
repeat
i:=i+1;
read(a[i]);
if (a[i] mod 2<>0) and (a[i] mod 3=0) then j:=j+1;
until (a[i]=0) or (i=1000);
writeln(Kolichestvo chisel - ,i-1);
writeln(Kolichestvo nechetnih chisel kotorie delatsa na 3 - ,j);
writeln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку