Даны действительные положительные числа a, b, c, которые являются длинами сторон треугольника. Напишите программу позволяющую найти радиус вписанной и описанной окружности

var
a,b,c,p,r1,r2:real;
begin
readln(a,b,c);
p:=(a+b+c)/2;
r1 := (a*b*c)/(4*sqrt(p*(p-a)*(p-b)*(p-c)));// описанная
r2 := sqrt(((p-a)*(p-b)*(p-c))/p);//вписанная
writeln(r1:1:5, ,r2:1:5);
readln;
readln
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку