Составить программу вычисления корней квадратного уравнения по данным значениям его коэффициентов

Var
a,b,c,d:real;
    begin
        writeln(a,b,c ?);
        readln(a,b,c);
        d:=sqr(b)-4*a*c;
            if d<0 then  writeln(d<0);   
                if d>0 then       
                     writeln(x1= ,((-b)+sqrt(d))/(2*a),  x2= ,((-b)-sqrt(d))/(2*a)) ;         
                         if d=0 then             
                            writeln(x1= ,(-b)/(2*a)); 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку