1. Составьте программу к задаче: «На яблоне было х яблок. В первый день с яблони упало а яблок. Каждый следующий день опадало в 2 раза больше яблок, чем в предыдущий. Сколько яблок останется через k дней?».

Паскаль:
#################################################################
var
x, k, a, i: integer;

begin
writeln(Введите количество яблок);
readln(x);
writeln(Введите количество дней);
readln(k);
writeln(Введите количество яблок, которое упало в 1 день);
readln(a);

for i:=1 to k do begin
x:=x-a;
a:=a*2;
end;

writeln(inttostr(x));
sleep(3000);

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку