составить программу в паскале как изменяетс ястепень найти сумму 2^3+ 2^5 + …+ 2^9

uses crt;
function step(n:integer):integer;
var p:integer;
begin
p:=2;
repeat
p:=p*2;
n:=n-1;
until n=1;
step:=p;
end;

var
a,sum,n:integer;
begin
n:=3;
repeat
sum:=sum+step(n);
n:=n+2;
until n>9;
write(sum);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку