Дан целочисленный прямоугольный массив 6x10. Опишите в программе "ПаскальАВС" алгоритм вычисления суммы минимальных элементов из каждой строки. Напечатать значение этой суммы. Предполагается, что в каждой строке минимальный элемент единственный.
Var
a:array [1..6,1..10] of integer; b,i,j,k,l: integer;
begin
b:=0;
for i:=1 to 6 do
begin
k:=32000;
for j:=1 to 10 do
begin
read(l);
if (l
b+=k;
end;
write(b);
end.
Проверено:
1 2 3 4 5 6 7 8 9 10
10 9 8 7 6 5 4 3 2 1
1 2 3 4 5 6 7 8 9 10
10 9 8 7 6 5 4 3 2 1
1 2 3 4 5 6 7 8 9 10
10 9 8 7 6 5 4 3 2 1
Ответ - 6
Оцени ответ
