Написать программу на Паскале,которая выведет на экран те строки из текстового файла, которые являются палиндромами. Имя файла вводить с клавиатуры.
Program proga_25_3;
var
A: text;
s,p : string;
i:integer;
f:boolean;
begin
write(Введите имя и путь к файлу );
read(p);
assign(A, p);
reset(A);
while not eof(A) do
begin
readln(A,s);
for i:=1 to length(s) div 2 do
if s[i]=s[length(s)-i+1] then
f:=true
else
begin
f:=false;
break;
end;
if f then
writeln (S);
end;
close(A);
end.
Оцени ответ
