Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000.
Программа должна вывести одно число: сумму всех чисел, которые кратны 6 или 11.
Var i,sum:integer;
begin
sum:=0;
repeat
readln(i);
if (i mod 6 = 0) or (i mod 11 = 0) then
sum:=sum+i;
until(i<>0);
write(sum);
end.
Оцени ответ
