Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а)в какой день он пробежал больше 20 км. б) в какой день суммарный пробег за все дни превысит 100 км? Задача по информатике, надо составить программу в pascal abc. Помогите!

а) 

var
i:integer;
p:real;
begin
i:=1;
p:=10;

repeat
p:=p + p*0.1;
i:=i+1;
until p>=20;
writeln(i, den);
end.

 

б)

var
i:integer;
p,n:real;
begin
i:=1;
p:=10;
n:=p;

repeat
n:=n+n*0.1;
p:=p + n;
i:=i+1;
write(n);
writeln( , p);
until p>=100;
writeln(i, den);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку