Помогите пожалуйста написать программу в pascal

Var a,d,max:integer; 
       begin     
           readln(a);               
               while a>0 do                   
                   begin                           
                         d:=a mod 4;                           
                                if d>max then                                 
                                      max:=d;                           
                        a:=a div 4;                                                
                  end;               
writeln(max);     
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку