Помогите составить задачу, которую можно решить с помощью цикла предусловия и соответственно написать программу в паскале.
Написать программу, которая выводит на экран суммуряда
пусть a – числитель;b – знаменатель;da и db – шаг длячислителя и знаменателя;n - для смены знака;
Программа:
const
da= -18; {927-945}
db=24; {33-9}
vara,b,n:integer;
s:real;
begin
s:=0;n:=1; a:=945;b:=9;
while a>=27 do
begin
s:=s+a/b*n; {подсчет суммы}
a:=a+da;
b:=b+db;
n:= -1*n; {изменение знака}
end;
writeln(s=,s:4:2);
end.
Оцени ответ
