ПАСКАЛЬ!
1)написать программу ,которая проверяет,является ли число четным или нечетным
2)Написать программу,которая проверяет,делится ли на 3 целое число введенное с клавиатуры
3)написать программу,которая определяет ,является билет "счастливым" или нет,билета 6-ти значное число .Билет является счастливым,если если сумма первых двух чисел равна сумме трех последних цифр
5)написать программу,которая проверяет ,делится ли на шесть целое число,введенное с клавиатуры
6)написать программу ,определяющую делится ли число b на число a нацело.
7)дано целое 4-х значное число . Поменять местами цифры,стоящие в этом числе в разные места,вывести на экран исходное и измененное число
1)))))))))
program z;
var
i : integer;
begin
Writeln(Введите число); Readln(i);
if i mod 2 = 0
then
Writeln(Число чётное)
else
Writeln(Число не чётное);
readln;
end.
2))))))))))))
program z;
var
i : integer;
begin
Writeln(Введите число); Readln(i);
if i mod 3 = 0
then
Writeln(Число делится на 3)
else
Writeln(Число не делится на 3);
readln;
end.
3))))))
program z;
var
i: array[1..6] of byte;
x:byte;
begin
for x:=1 to 6 do
begin
Writeln(Введите , x, цифру из 6 );
Read(i[x]);
end;
if (i[1]+i[2]) = (i[4]+i[5]+i[6])
then
Writeln(Билет счастливый)
else
Writeln(Билет не счастливый);
Readln;
end.
5)))
program z;
var
i : integer;
begin
Writeln(Введите число); Readln(i);
if i mod 6 = 0
then
Writeln(Число делится на 6)
else
Writeln(Число не делится на 6);
readln;
end.
6)))))
program z;
var
a,b:integer;
begin
Writeln(Введите число A); Readln(a);
Writeln(Введите число B); Readln(b);
if b mod a = 0
then Writeln(Число А делится нацело на число В)
else Writeln(Число А не делится нацело на число B);
Readln;
end.
