По координатам трех вершин некоторого треугольника найти его площадь и периметр. Написать программу Delphi7.

Это код консольного приложения

program Project2;

{$APPTYPE CONSOLE}

uses
  SysUtils, Windows;

function storona(x1,y1,x2,y2: real): real;
var s: real;
begin
  s:=sqrt(sqr(x1-x2)+sqr(y1-y2));
  storona:=s;
end;

var
  x1,y1,x2,y2,x3,y3: real;
  l1,l2,l3: real;
begin
  //Переключение окна консоли на кодовую страницу CP1251 (Win-1251).
  //Если после переключения русские буквы показываются неверно,
  //следует открыть системное меню консольного окна - щелчком мыши в левом
  //верхнем углу окна консоли и выбрать:
  //Свойства - закладка "Шрифт" - выбрать шрифт: "Lucida Console".
  SetConsoleCP(1251);
  SetConsoleOutputCP(1251);
  write(Введите координаты точки А: );
  readln(x1,y1);
  write(Введите координаты точки B: );
  readln(x2,y2);
  write(Введите координаты точки C: );
  readln(x3,y3);
  l1:=storona(x1,y1,x2,y2);
  l2:=storona(x2,y2,x3,y3);
  l3:=storona(x1,y1,x3,y3);
  if (l1>l2)and(l1>l3) then
  begin
    writeln(Периметр прямоугольника = ,(l2+l3)*2:6:2);
    writeln(Площадь прямоугольника = ,l2*l3:6:2)
  end;
    if (l2>l1)and(l2>l3) then
  begin
    writeln(Периметр прямоугольника = ,(l1+l3)*2:6:2);
    writeln(Площадь прямоугольника = ,l1*l3:6:2)
  end;
    if (l3>l1)and(l3>l2) then
  begin
    writeln(Периметр прямоугольника = ,(l1+l2)*2:6:2);
    writeln(Площадь прямоугольника = ,l1*l2:6:2)
  end;
  readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку