Написать программу, которая заменяет все заглавные буквы строчными, а строчные – заглавными в заданной символьной строке. (Паскаль)

Program X; //работает только для русских строк
var   
    i: longint;   
    s: string;
begin
    readln(s);
    for i := 1 to length(s) do
        if (ord(s[i]) >= 192) and (ord(s[i]) <= 223) then
            s[i] := chr(ord(s[i]) + 32)
        else if (ord(s[i]) >= 224) and (ord(s[i]) <= 255) then
            s[i] := chr(ord(s[i]) - 32);
    writeln(s)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку