Реализовать с помощью 3-х циклов: while, repeat, for) Составить программу, которая выдавала бы сообщение ‘ true ‘, если последовательность из N целых чисел, вводимых с клавиатуры, является возрастающей
Это реализовано с помощью цикла for:
Program p1;
Var a1,a2,k,i:integer;
Begin
Write(Введите число: );
Readln(a1);
For i:=0 to 1 do
Begin
Write(Введите число: );
Readln(a2);
if a2>a1 then
k:=k+1;
a1:=a2;
End;
if k=2 then
Writeln(Эта последовательность является возрастающей) else
Writeln(Эта последовательность не является возрастающей);
End.
Это реализовано с помощью цикла while:
Program p2;
Var a1,a2,k,i:integer;
Begin
Write(Введите число: );
Readln(a1);
While i<>2 do
Begin
Write(Введите число: );
Readln(a2);
if a2>a1 then
k:=k+1;
a1:=a2;
i:=i+1;
End;
if k=2 then Writeln(Эта последовательность является возрастающей) else Writeln(Эта последовательность не является возрастающей);
End.
Это реализовано с помощью цикла repeat:
Program p3;
Var a1,a2,k,i:integer;
Begin
Write(Введите число: );
Readln(a1);
repeat
Begin
i:=i+1;
Write(Введите число: );
Readln(a2);
if a2>a1 then
k:=k+1;
a1:=a2;
End;
until i=2;
if k=2 then
Writeln(Эта последовательность является возрастающей) else
Writeln(Эта последовательность не является возрастающей);
End.
