Программирование в СИ++ !
Нужно написать программу, в которой 2 переменные типа float в main() являются локальными, а после используются в функции, которая вычисляет квадраты этих чисел.
Пожалуйста, исправьте мои ошибки.
#include
#include
#include
#include
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
printf_s("Квадрат первого числа равен:%fn", ch1);
printf_s("Квадрат второго числа равен:%fn", ch2);
system("pause");
return(0);
}
int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
printf_s("Введите первое число:");
scanf_s("%f", &a);
printf_s("Введите второе число:");
scanf_s("%f", &b);
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
}
+ Напишите программу с возвратом значений

Можно вот так, например (проверено в Dev C++):

#include
#include
using namespace std;
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
cout<<"Квадрат первого числа равен:"<cout<<"Квадрат второго числа равен:"<return(0);
}

int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
cout<<"Введите первое число:";
cin>>a;
cout<<"Введите второе число:";
cin>>b;
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
system("PAUSE");
}


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку