Помогите, пожалуйста, в Паскале. Составить программу, по которой компьютер находит произведение нечетных чисел, начиная с единицы, и до тех пор, пока на вопрос, задаваемый после каждого шага вычислений: «Продолжить вычисления? (Д/Н)», отвечают ‘Д’.

Var  a:longint;  b:integer;  s:string;  
begin 
 readln(s); 
 a:=1;  b:=1; 
 repeat   
  writeln(Продолжить вычисления? (Д/Н));   
  b:=b+2;   
  a:=a*b;   
  readln(s); 
 until (s<>Д); 
 write(a);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку