Напишите программу в Паскале)
написать программу которая вычисляет дату следующего дня.
Введите цифрами сегодняшнюю дату(число,месяц,год) 31 12 1998

Program z2;
var day, month, year:integer;
begin
writeln(Введите число, месяц, год);
readln(day,month,year);
if(year mod 4=0) and (year mod 100 <> 0) or (year mod 100=0) and (year mod 400 = 0) then  //определение висок. года
begin 
 if(month=2) then 
  begin
     if(day=29) then
    begin     
day:=1;     
month:=3;   
end   
else     
day:=day+1; 
end 
else if(month=1) or (month=3) or (month=5) or( month=7) or (month=8) or (month=10) then
  begin   
if(day=31) then   
begin     
month:=month+1;     
day:=1;   
end   
else     
day:=day+1; 
end 
else if(month=12)then 
begin   
if(day=31) then     
begin       
year:=year+1;       
month:=1;       
day:=1;     
end   
else     
day:=day+1; 
end 
else    
begin
    if(day=30) then
      begin
        day:=1;
        month:=month+1;
      end
    else
     day:=day+1;
    end;
end
else //проверка обычного года
begin
  if(month=2) then
  begin
     if(day=28) then
    begin
      day:=1;
      month:=3;
    end
    else
      day:=day+1;
  end
  else if(month=1) or (month=3) or (month=5) or( month=7) or (month=8) or (month=10) then
  begin
   if(day=31) then
    begin
      month:=month+1;
      day:=1;
    end
    else
      day:=day+1;
  end
  else if(month=12)then
  begin
    if(day=31) then
      begin
        year:=year+1;
        month:=1;
        day:=1;
      end
    else
      day:=day+1;
  end
  else
     begin
    if(day=30) then
      begin
        day:=1;
        month:=month+1;
      end
    else
     day:=day+1;
    end;
end;
writeln(Следующий день: ,day, ,month, ,year);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку