Напишите программу, которая вычисляет сумму цифор только трехзначных чисел

Var a,b,c,d:integer;
begin
writeln(Введите число:);
readln(a);
if (a div 1000=0) and (a div 100>0)  then begin
b:=a div 100;
c:=a div 10 - (a div 100) * 10;
d:=a - (a div 10)*10;writeln(b+c+d);
end
else writeln(Вы ввели не трехзначное число.);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку