Нужна помощь с информатикой всего 2 задачи! Даю много баллов)
Напишите программу которая находит минимальное и максимальное среди чётных положительных чисел записанных в файле и выводит результат в другой файл
В файле записано не более 100 целых чисел вывести в другой текстовый файл те же числа отсортированные в порядке возрастания
Задача 1.
var
f:Text;
n,nmax,nmin:integer;
begin
Assign(f,input.txt); Reset(f);
nmax:=-32786; nmin:=32767; {границы представления integer}
while not Eof(f) do begin
Readln(f,n);
if (n>0) and (n mod 2=0) then
if nmax
if nmin>n then nmin:=n
end;
Close(f);
Assign(f,output.txt); Rewrite(f);
Writeln(f,nmin, ,nmax);
Close(f)
end.
Задача 2.
const
m=100; { максимальное количество чисел в файле }
var
f:Text;
i,j,n,k:integer;
a:array[1..m] of integer;
begin
{ читаем данные из файла в массив }
Assign(f,input.txt); Reset(f);
i:=0;
while not Eof(f) do begin Inc(i); Readln(f,a[i]) end;
Close(f);
n:=i;
{ сортируем массив по возрастанию методом пузырька }
for i := 1 to n-1 do
for j := 1 to n-i do
if a[j] > a[j+1] then
begin k := a[j]; a[j] := a[j+1]; a[j+1] := k end;
{ заполняем файл из массива }
Assign(f,output.txt); Rewrite(f);
for i:=1 to n do Writeln(f,a[i]);
Close(f)
end.
Вложение: пример файла input.txt
