Напишите программу, которая находит минимальное и максимальное среди чётных положительных чисел, записанных в файле, и выводит результат в другой файл. Учтите, что таких чисел может вообще не быть.
(Язык программирования Паскаль)

{Напишите программу, которая находит минимальное и максимальное
среди чётных положительных чисел, записанных в файле,
и выводит результат в другой файл.}
var f:text;
  min, max,a :integer;
  find:boolean;{есть/нет числа удовлетворяющие условию}
begin
 assign(f,dan.txt); reset(f);
 min:=0; max:=0;
 find:=false;
 while not eof(f) do
 begin
  read(f,a);
  if not find and (a>0) and (a mod 2=0) then
  begin
   min:=a; find:=true;
  end
  else
  if find and (a>0) and (a mod 2=0) and (min>a) then
   min:=a;

  if (a>0) and (a mod 2=0) and (max   max:=a;
 end;
 close(f);
 assign(f,res.txt);
 rewrite(f);
 if max=0 then writeln(f,чётных положительных чисел нет)
  else
   writeln(f,min среди чётных положительных чисел =,min, chr(13),
      max среди чётных положительных чисел нет,max);
  close(f);
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку