Напишите программу, которая в последовательности натуральных чисел определяет количество трёхзначных чисел, кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество трёхзначных чисел, кратных 4.
Var
x, count:integer;
begin
repeat
readln(x);
if (x >= 100) AND (x <= 999) AND (x mod 4 = 0) then
count := count + 1;
until x = 0;
writeln(count);
end.
Оцени ответ
