Одномерные массивы: Составить программу, заполняющую массив, состоящий из N элементов, введенными с клавиатуры целыми числами. Требуется вывести массив на экран компьютера и найти индекс последнего по счету в массиве отрицательного элемента.

Var n:array [1..999] of integer;
a,i,c:integer;
begin
write (Введите кол-во элементов: );
readln (a);
c:=0;
for i:=1 to a do
begin
write (Введите ,i, элемент: );
readln (n[i]);
if n[i]<0 then c:=i;
end;
WRITELN;
write (Введённый массив: );
for i:=1 to a do
begin
write (n[i], );
end;
WRITELN;
if c>0 then writeln (Индекс последнего введённого отрицательного элемента ,c) else writeln (Отрицательных элементов не было введено!);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку