13. Для какого значения числа Z высказывание ((Z > 2)Ú(Z > 4)) →(Z > 3) будет ложным?
14. Определите значение переменной c после выполнения следующего фрагмента программы, в котором a, b и c – переменные целочисленного типа:
a := 27;
b := 13;
if b div 5 > 2
then
​c := b mod 5 + a mod 3
else
​c := (b + a) mod 6;
15. Определите, что будет напечатано в результате работы следующего фрагмента программы?
var n, s, d: integer;
begin
readln(d);
n := 3;
s := 57;
for i:= 2 to 5 do begin
s := s + n;
n := n + 4
end;
write(s)
end.

13. Для z = 3;
14 т.к b div 5= 2
  ​c := (b + a) mod 6;
  c:=   40 mod 6
  c:= 4
15. Ничего не будет напечатано, т.к программа не будет работать:
     Паскаль будет ругаться, что не объявлен идентификатор i.
       Но если бы он был, то на экран бы выводилось число 93 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку