Напишите программу, которая ввод данных в одномерный целочисленный массив осуществляет
посредством цикла WHILE...DO, а вывод – REPEAT...UNTIL (в скобках указана размерность массива):
заменить все элементы массива, которые меньше среднего значения, на «3» (12).

Const N=12;
var a: array[1..N] of integer;
    avg:real;
    i:byte;
begin
 writeln(Введите массив из ,N, элементов);
 i:=0; avg:=0;
 while i begin
  i:=i+1 ;
  read(a[i]);
  avg:=avg+a[i];
 end;
 avg:=avg/n;
 i:=0;
 writeln(Исходный массив);
 repeat
  i:=i+1;
  write(a[i]:5);
 until i>=n;
 writeln;
 writeln(Отредактированный массив);
 i:=0;
 repeat
  i:=i+1;
  if a[i]  write(a[i]:5);
 until i>=n;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку