Напишите программу которая выводит на экран (Паскаль)
а)положительные числа
б)отрицательные
в)четные
г)нечетные
На заметку(числа произвольные или любые (integer))
Исправлено:Даёться массив из N чисел вывести на экран количесвто чётных и нечётных,количество положительных и отрицательных элементов массивов

Числа вводятся пользователем. Прикрепил скрин работы программы, вот сама программа:

var a:array[1..999]of integer;
i,n:integer;
begin
write (Введите кол-во чисел: );
readln (n);
for i:=1 to n do
begin
write (Введите ,i, число: );
readln (a[i]);
end;
WRITELN;
write (Числа введённые пользователем: );
for i:=1 to n do
write (a[i], );
WRITELN;
WRITELN;
write (Положительные: );
for i:=1 to n do
begin
if a[i]>0 then write (a[i], );
end;
WRITELN;
write (Отрицательные: );
for i:=1 to n do
begin
if a[i]<0 then write (a[i], );
end;
WRITELN;
write (Чётные: );
for i:=1 to n do
begin
if a[i] mod 2 = 0 then write (a[i], );
end;
WRITELN;
write (Нечётные: );
for i:=1 to n do
begin
if a[i] mod 2 <> 0 then write (a[i], );
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку