Задачи паскаль, помогите пожалуйста кто.

1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне 1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

1. 

var   n: integer;  

begin  

repeat  

writeln(Введите номер месяца [1..12]);  

  readln(n);   until n in [1..12];

  case n of  

  1: writeln(January);  

  2: writeln(February);  

  3: writeln(March);  

  4: writeln(April);  

  5: writeln(May);  

  6: writeln(June);  

  7: writeln(July);  

  8: writeln(August);  

  9: writeln(September);

  10: writeln(October);  

  11: writeln(November);  

  12: writeln(December);

  end;

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку