Pascal
Уравнение
Написать программу решения уравнений вида (не обязательно квадратное)
a*X^2 + b*X + c = 0.
Коэффициенты запрашиваются с экрана и могут быть ЛЮБЫМИ действительными числами.
Результатом работы программы является либо вывод корней уравнения, либо вывод
какого-то сообщения. Само уравнение тоже должно быть выведено на экран.
Program a;
var D,a,b,c: real;
begin
Readln(a,b,c);
//a*X^2 + b*X + c = 0
writeln (a,*X^2 + ,b,*X + ,c, = 0);
D:=b*b-4*c*a;
if (d<0) then writeln (D<0!) else
if (d=0) then writeln (X= ,(-b+sqrt(D))/2) else
if (d>0) then writeln (X1= ,(-b+sqrt(D))/(2*a):0:1,; X2= ,(-b-sqrt(D))/(2*a):0:1);
end.
Оцени ответ
