Информатики!!! Помогите, срочно надо!! ВОТ ЗАДАЧА:
Пользователь вводит с клавиатуры 3 числа a, b, c , являющиеся сторонами треугольника. Написать программу использующую подпрограмму функцию для вычисления площади треугольника по формуле Герона. (В паскале) Напишите пожалуйста программу
Формула Герона: S=p*(p-a)(p-b)(p-c) (все под корнем). p=a+b+c/2
Var
p,x,y,z:real;
function s(a,b,c:real):real;
begin
p:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c))
end;
begin
readln(x,y,z);
s(x,y,z);
writeln(s(x,y,z));
end.
Оцени ответ
