Дано натуральное число определите сколько раз в нем встречается максимальная цифра ( пример 133 ответ 2 , 228 ответ 1 )
помогите очень нужно

Var
  n:longint;
  i,d,dmax:byte;
  a:array[0..9] of byte;
begin
  Writeln(Введите натуральное число (1..2147483647): );
  Read(n);
  for i:=0 to 9 do a[i]:=0;
  dmax:=0;
  while n>0 do begin
    d:=n mod 10;
    if dmax    Inc(a[d]);
    n:=n div 10
  end;
  Writeln(Максимальная цифра ,dmax, встречается ,a[dmax], раз(а))
end.

Тестовое решение:
Введите натуральное число (1..2147483647):
235636634
Максимальная цифра 6 встречается 3 раз(а)

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку