Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений. (на паскале)
program qq;
const
N=100;
var a: array [1..N] of integer;
i,min,max : integer;
begin
min:=0; max:=0;
cls;
writeln (Массив [-20;+20]);
for i:=1 to N do begin
A[i]:=random (40)-20;
write (A[i]:4);
if A[i] < 0 then
min:=min+A[i]
else max:=max+A[i];
end;
writeln;writeln;
writeln (Cумма положительных элементов: , max);
writeln (Cумма отрицательных элементов: , min);
end.
Оцени ответ
