Даны два неравных целых двухзначных числа. Возвести в квадрат большее из этих чисел и удвоить меньшее число. Написать программу для паскаль.
Это решение при задании вручную этих чисел:
Program sadadasf;
var i,k,l: integer;
begin
Writeln(Введите первое целое двухзначное число:);
readln(i);
Writeln(Введите второе целое двухзначное число:);
readln(k);
If k>i then begin
k:=k*k;
i:=i*2;
end;
If i>k then begin
i:=i*i;
k:=k*2;
end;
Writeln(Первое число:, i);
Writeln(Второе число:, k);
end.
Это решение при задании чисел в самой программе:
Program sadadasf;
var i,k,l: integer;
begin
i:=5;
k:=3;
If k>i then begin
k:=k*k;
i:=i*2;
end;
If i>k then begin
i:=i*i;
k:=k*2;
end;
Writeln(Первое число:, i);
Writeln(Второе число:, k);
end.
Оцени ответ