Найдите количество целых чисел на
интервале [100;25000], у которых сумма цифр в десятичной и пятеричной системах счисления одинаковые. В ответе укажите целое число без пробелов и знаков препинания, например, 19
Var a,b: array [100..25000] of integer;
i,k,n,p:integer;
Begin
for i:=100 to 25000 do
begin
b[i]:=i;
a[i]:=i;
n:=0;
while a[i]>0 do
begin
n:=n+(a[i] mod 10);
a[i]:=a[i]div 10;
end;
p:=0;
while b[i]>0 do
begin
p:=p+(b[i] mod 5)
; b[i]:=b[i]div 5;
end;
if(n=p) then inc(k);
end;
writeln(k);
end.
Оцени ответ