Написать программу для определения веса человека. Запросить рост в см, возраст и его вес. рассчитать норму веса по формуле:
Если возраст меньше 25, то использовать формулу НОРМА ВЕСА = РОСТ -110, иначе НОРМА ВЕСА= РОСТ -100
Вывести сообщение:
Если НОРМА ВЕСА=ВЕСУ, то "ваш вес в норме"
Если НОРМА ВЕСА<ВЕСА, то "вам надо сбросить n килограмм"
Если НОРМА ВЕСА>ВЕСА, то "вам надо поправиться на n килограмм"
Var r,v,w,n,kg:real;
begin
write (Введите рост: );
readln (r);
write (Введите возраст: );
readln (v);
write (Введите вес: );
readln (w);
WRITELN;
if v<25 then n:=r-110 else n:=r-100;
if n=w then writeln (Ваш вес в норме);
kg:=w-n;
if n
if n>w then writeln (вам надо поправится на ,kg, килограмм);
end.
Оцени ответ
