Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от -10 до 20. Составьте программу, которая подсчитывает и выводит среднюю температуру по всем дням, когда были заморозки. Гарантируется, что хотя бы в один день были заморозки
//дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от -10 до 20.
//Составьте программу, которая подсчитывает и выводит среднюю температуру по всем дням,
//когда были заморозки. Гарантируется, что хотя бы в один день были заморозки
var i,x,y : shortint;
s : real;
t : array [1..30] of shortint;
begin
randomize;
For i:=1 to 30 do
begin
t[i]:=random (31)-10; //заполняем таблицу случайным образом (в диапазоне от -10 до 20)
writeln (i, ,t[i]); //строка не обязательная просто позволяет увидеть заполненный массив
end;
for i:=1 to 30 do
begin
if t[i]<0 then
begin
x:=x+t[i];
y:=y+1;
end;
end;
s:=x/y;
writeln (Средняя температура по дням, когда были заморозки ,s:0:2);
end.
