
Определим как «красивое» целое положительное трехзначное число Х, для которого выполняется следующее условие: сумма квадратов первой и последней цифр
равна квадрату средней цифры. Напишите программу, которая выводит на экран все «красивые» числа и их количество.

program zadacha_1;
var a,b,c,a2,d:integer;
begin d:=0;
for a:=100 to 999 do begin
a2:=a;
b:=a2 mod 10;
a2:=a2 div 10;
c:=a2 mod 10;
a2:=a2 div 10;
if sqr(b)+sqr(a2)=sqr(c) then writeln(a);
if sqr(b)+sqr(a2)=sqr(c) then d:=d+1 ;
end;
writeln(количество ==>, d);
end.
Оцени ответ