Помогите пожалуйста написать на Паскале!
Написать программу, которая запрашивает массив из N целых чисел, а затем складывает все элементы с нечетными номерами и все элементы с четными номерами и выводит их сумму, а также сам исходный массив.
Var
a:array [1..100] of integer;
n,i,s1,s2:integer;
begin
writeln(введите кол-во эл-тов массива);
readln(N);
for i:=1 to n do
begin
read(a[i]);
if i mod 2<>0 then s1:=s1+a[i]
else s2:=s2+a[i];
end;
writeln;
writeln(Исходный массив);
for i:=1 to n do
write(a[i]:7);
writeln(сумма элементов с нечетными номерами,s1);
writeln(сумма элементов с четными номерами,s2);
end.
Оцени ответ
