Нужно написать программу. Найдите сумму цифр не кратных 3 и произведение цифр больших 5 в записи числа.
var
a,b,s,p : integer;
begin
readln (a);
s := 0;
p := 1;
while a > 0 do
begin
b := a mod 10;
a := a div 10;
if b mod 3 <> 0 then
s := s + b;
if b > 5 then
p := p * b;
end;
if p = 1 then
p := 0;
writeln (s);
writeln (p);
end.
Оцени ответ
