Для данного N составить алгоритм вычисления значения выражения: sin1 + sin2 + sin3! + sin4! + … + sinN!
Var
fact,s:real;
i,n:integer;
begin
Write(Введите натуральное N: ); Read(n);
s:=0; fact:=1;
for i:=1 to n do
begin fact:=i*fact; s:=s+sin(fact) end;
Writeln(s=,s)
end.
Тестовое решение:
Введите натуральное N: 5
s=1.14638573564034
Оцени ответ
