Помогите пожалуйста!!! Дан вещественный вектор длины n найти min элемент среди положительных компонент массива.
нужно написать программу в Pascal.
Решение в PascalABC.Net:
const
n=20;
var
a:array[1..n] of real;
i:integer;
amin:real;
begin
Randomize;
Writeln(Элементы массива);
amin:=100;
for i := 1 to n do
begin
a[i]:=50*Random-25;
Write(a[i]:8:3);
if (amin>a[i]) and (a[i]>0) then amin:=a[i]
end;
Writeln;
Writeln(Минимальный среди положительных элемент: ,amin:0:3);
end.
Тестовое решение:
Элементы массива
-2.958 -12.624 -15.038 10.972 -14.160 -4.612 -8.148 14.052 22.818 -2.376 6.954 22.090 7.510 -21.058 -17.434 -1.651 24.170 -15.143 9.159 -6.910
Минимальный среди положительных элемент: 6.954
Оцени ответ
