Задана строка символов. Группа символов, разделенные пробелом и не содержащие внутри себя, будем называть словами. Определить количество слов, которые содержат ровно две буквы а. Необходимо написать программу в ПАСКАЛЬ
var
s : string;
l,i,k,a : integer;
begin
readln (s);
l := Length(s);
k := 0;
a := 0;
for i := 1 to l do
begin
if (s[i]= ) or (i=l) then
begin
if a = 2 then
k := k +1;
a := 0
end
else
if s[i] =a then
a := a +1;
end;
writeln(k);
end.
Оцени ответ
