Помогите умоляю решается судьба атестата
напишите решение задач, пожалуйста
Решите задачи:
Арифметический цикл For
1. Остров Манхэттен (район Нью-Йорка) был выкуплен индейцев переселенцами из Амстердама в 1626 г. всего за 24 $. Каково было бы в настоящее время состояние их счета, если бы эти деньги были помещены тогда в банк под 7% годового дохода?
2. Напишите программу, чтобы получить перевертыш целого четырехзначного числа n, введенного пользователем (вспомните, как разбить число на разряды с помощью операций div и mod)?
Итерационный цикл Repeat
1. Через сколько дней в зоне заражения уровень радиации упадет до безопасного значения 30 микрорентген в час, если начальное значение уровня заражения Z и каждый день оно уменьшается на 5% по отношению к предыдущему дню. Для проверки:
700 = 62 дня
19500 = 127 дней
Итерационный цикл While
1. Напишите программу, чтобы определить, сколько лет нужно хранить К долларов в банке под Р % годовых, чтобы стать миллионером?
2. На склад привозят однородный груз на машинах различной грузоподъемности. Пользователь вводит информацию о весе груза очередной машины. Составить программу подсчета количества машин, прибывших на склад до его заполнения, если вместимость склада не более 100 тонн.

//1.
const god1=1626;
      god2=2015;            bank=0.07;      var
summa:real;
begin
summa:=24;
for var  i:=god1 to god2 do
summa:=summa+(summa*bank);
writeln(summa);
end.
//2.
var
a,b:integer; 
begin
read(a);
b:=0;
for var i:=1 to length(inttostr(a))  do begin
b:=b*10+a mod 10; a:=a div 10;
end;
writeln(b);
end.
//3.
const s=0.05;
var 
d:integer;
z:real;
begin
read(z);
d:=0;
repeat
inc(d);
z:=z-z*s;
until z<=30;
writeln(d);
end.
//4.
var
b,c:integer;
a:real;
begin
writeln(Кол-во $ и какой проц. годовых?);
readln(a,b);
c:=0;
while a<1000000 do begin
a:=a+a*(b/100);
inc(c);
end;
writeln(c);
end.
//5.
const max=100;var
a,b,c,d:integer;
begin
b:=0;
writeln(Кол-во машин?);
read(d);
writeln(Перечислите вес груза);
read(a);
c:=a;
for var i:=1  to d-1 do begin
read(a);
while c<=max do begin
inc(b);
c:=c+a;
end;
end;
writeln(b);
end.
//ABC Pascal

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку