С клавиатуры вводится несколько чисел.Найти сумму чисел кратных 5 и кол-во положительных.

Var a:array [1..999] of integer;
i,n,p,m:integer;
begin
m:=0;
write (Сколько чисел собираетесь ввести?: );
readln (n);
for i:=1 to n do
begin
write (Введите ,i, число: );
readln (a[i]);
if a[i]>0 then p:=p+1;
if a[i] mod 5=0 then m:=m+a[i];
end;
WRITELN;
writeln (Вы ввели ,p, положительных чисел.);
writeln (Сумма чисел кратных 5 = ,m);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку