Задача:
Дан массив из 10 целых чисел,от -20 до 20 .
Напишите программу,заменяющую первый отрицательный элемент массива нулем.
Помогите пожалуйста решить!

var a:array [1..10] of integer;
     i,n,b:integer;
Begin
  for i:=1 to 10 do
    read(a[i]);
  for i:=1 to 10 do
  begin
    if b=0 then if a[i]<0 then 
       begin
         a[i]:=0;
         b:=1;
       end;
  end;

  for i:=1 to 10 do
  write(a[i], );
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку