Помогите написать программу в паскале.
В заданном массиве найти количество чётных чисел. Вывести исходный массив и результат.
Вариант с вводом элементов:
Program prog;
uses crt;
var a: array [0..999] of integer;
i, k, n: integer;
begin
clrscr;
write(Размер массива n = );
readln(n);
writeln;
for i:=1 to n do
begin
write(a[,i,] = );
readln (a[i]);
end;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln;
writeln(Количество четных чисел k = , k);
end.
Вариант с рандомными элементами:
Program prog;
uses crt;
var a: array [0..999] of integer;
i, k, n: integer;
begin
clrscr;
randomize;
write(Размер массива n = );
readln(n);
writeln;
for i:=1 to n do
begin
a[i]:=random(100)-50;
writeln(a[,i,] = ,a[i]);
end;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln;
writeln(Количество четных чисел k = , k);
end.
Оцени ответ
