Автомат принимает трёхзначное число, вычисляет сумму двух старших разрядов (сотен и десятков), а также сумму двух младших разрядов( десятков и единиц). Затем эти суммы выводятся на экран в порядке возрастания(без пробелов). Напишите программу, которая моделирует работу автомата

{с клавиатуры вводится число до тех пор, пока не будет введено 3-х значное, сумма первых двух цифр записывается в a, сумма десятков и единиц - в b. Сравнивается какое из них больше и выводится в порядке возрастания}
Uses Crt;
var
a,c,b:integer;
begin
   ClrScr;
      repeat
          writeln(INPUT 3-x znachoe);
           readln(b);
      until (b>=100)and(b<=999);
a:=b div 100+(b div 10)mod 10;
c:=(b div 10)mod 10+b mod 10;
     if a         writeln(a,c)
else
         writeln(c,a);
Readkey;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку